Locali scaduti

Antefatto

Martedì sera 12 giugno mi trovavo a Frosinone; mia moglie doveva fare il turno di notte a lavoro e, come accade in questi casi, prendiamo qualcosa da mangiare in qualche locale della zona. Siccome ogni tanto mi piace cambiare, invece di ordinare dal solito (e sempre buono) Pepe Nero, decidiamo di provare la “pinsa” del Salun, un ristopub nella parte bassa della città. Arrivo, chiedo due pinse con bufala e una porzione di pasta al pomodoro, tutto da portare via. Visto che mangiavamo pizza, chiedo anche due birre, in particolare due birre artigianali, anche perché la scelta era molto limitata. La persona che mi ha servito mi ha fatto notare che si trattava di birra stout (quella nera), che magari con la pizza non era proprio il massimo. Raccolgo il suggerimento e opto per una birra bionda più tradizionale (non ricordo la marca) e una stout artigianale, entrambe ovviamente in bottiglia. Leggi tutto “Locali scaduti”

Startup di merda

Qualche giorno fa stavo sbirciando su Amazon alla ricerca di qualche libro che parlasse di startup e, tra i vari risultati, mi ha colpito un titolo alquanto singolare: “Startup di merda”, di Mario Moroni. Incuriosito, ho scaricato ed iniziato a leggere l’anteprima della versione Kindle, e sono bastate pochissime pagine per convincermi all’acquisto dell’e-book.

Il libro, come è facile intuire, ha lo scopo di convincere potenziali imprenditori a valutare attentamente l’opportunità di avviare un nuovo business con l’obiettivo di diventare ricchi e famosi grazie a una qualche idea innovativa e rivoluzionaria. Il motivo? Semplice: nove startup su dieci, in Italia e nel resto del mondo, falliscono miseramente nel giro di poco tempo, lasciandosi dietro debiti e disperazione.

L’autore descrive gli errori più comuni degli startuppari, sfatando miti e leggende particolarmente diffusi tra giovani imprenditori cresciuti con l’ideale del miliardario che ha dato inizio al suo successo partendo da un garage e senza il becco di un quattrino.

La realtà, spiega Moroni, è ben diversa e disseminata di innumerevoli pericoli ai quali soltanto i più preparati e i più avveduti riescono a sopravvivere. Se hai in mente di avviare una startup in un determinato settore, spiega l’autore, devi necessariamente essere esperto di quel settore e devi circondarti delle persone giuste in grado di colmare le tue eventuali lacune nel modo più efficace possibile. Devi anche essere pronto a sacrificare tempo, sonno, vacanze, relazioni e divertimenti per diversi anni se vuoi riuscire a tenerti a galla e non affondare al verificarsi delle prime difficoltà.

Il libro si legge in poche ore, è scritto in uno stile leggero, divertente ed irriverente, con il linguaggio tipico di chi, avendo vissuto in prima persona certe esperienze, vuole comunicare il suo messaggio nel modo più diretto possibile. L’autore raggiunge il suo scopo? Probabilmente no, perché chi ha in testa la sua idea e coltiva da tempo dentro di sé la voglia di realizzarla, non si farà scoraggiare da un libro scritto da chi, tutto sommato, alla fine l’ha sfangata ed è riuscito a non farsi ingoiare dal mare di merda che seppellisce nove startup su dieci.

Fregature on-line: il caso Play Sea

Occupandomi di sicurezza informatica, raccontare questo episodio non mi fa fare una gran bella figura, ma d’altra parte serve a dimostrare che nessuno è immune e che non bisogna mai abbassare la guardia.

Si stava avvicinando il compleanno di mia figlia e quindi bisognava scegliere un regalo da parte di mamma e papà, e quando si tratta cercare regali mia moglie è molto più attiva e veloce di me. Quindi solitamente succede che lei trova il giusto regalo (quasi sempre on-line), mi manda il link e io pago. Nel 90% dei casi si tratta di comprare su Amazon, altre volte su siti che accettano pagamenti via PayPal. Stranamente questa volta il link portava ad un sito che chiedeva direttamente la carta di credito, cosa un po’ rara per le mie abitudini di acquisti in rete. Tuttavia, dato che il link me lo aveva mandato una persona fidata ho dato per scontato che fosse un sito affidabile e ho proceduto alla registrazione del mio account e all’acquisto con carta di credito (in realtà una carta prepagata contenente poco più della somma che avevo preventivato di spendere). Risultato: la sessione https seguente il checkout è andata in timeout e a me non è arrivata nessuna conferma dell’acquisto. Tuttavia, riloggandomi sul sito e andando nel mio profilo, risultava che il pagamento (di  circa 146 euro) era andato a buon fine e che l’ordine era in fase “pending”. Segnalo immediatamente l’anomalia scrivendo all’indirizzo indicato per i contatti, aspettando una risposta nel giro di qualche ora. Nel frattempo continuo con i miei acquisti su altri siti (fidati). Leggi tutto “Fregature on-line: il caso Play Sea”

RouterOS – configurare le SVI

L’acronimo SVI sta per Switched Virtual Interface e, almeno nel mondo Cisco IOS, si riferisce alle interfacce layer 3 virtuali associate alle VLAN di uno switch. Configurare una SVI su uno switch Cisco è abbastanza banale, è sufficiente creare una VLAN e poi configurare la corrispondente SVI entrando nella modalità di configurazione interface vlan X (dove X è il vlan-id). Esempio:

cisco-sw# conf t
cisco-sw(config)# vlan 10
cisco-sw(config-vlan)# name server
cisco-sw(config-vlan)# exit
cisco-sw(config)# interface vlan 10
cisco-sw(config-if)# ip address 192.168.6.1 255.255.255.0
cisco-sw(config-if)# interface fa0/1
cisco-sw(config-if)# interface mode trunk
cisco-sw(config-if)# interface trunk allowed vlan 10

Nella pratica si può anche evitare la creazione esplicita della VLAN e passare direttamente alla configurazione della SVI; la vlan corrispondente sarà creata automaticamente. Le ultime righe del precedente frammento si riferiscono alla configurazione di un trunk sull’interfaccia fast ethernet 0/1 su cui transiteranno i pacchetti della vlan 10.

Veniamo ora all’argomento del post, ovvero creare una SVI su un dispositivo RouterOS. I passaggi sono un po’ meno intuitivi, soprattutto per chi non ha familiarità con la sintassi di questo sistema operativo.

Per prima cosa definiamo una nuova vlan e la colleghiamo ad una specifica interfaccia fisica:

/interface vlan
 add comment="LAN server" interface=ether1 name=vlan10 vlan-id=10

In questo modo la nostra vlan, il cui id è 10, risulta configurata sull’interfaccia ether1, che si comporterà quindi come un trunk dot1q. Il commento e il nome dell’interfaccia (parametri comment e name) sono arbitrari, ma il nome ci servirà più avanti.

Configuriamo adesso l’IP per la nostra SVI:

/ip address
 add address=192.168.6.1/24 comment="SVI vlan server" interface=vlan10 network=192.168.6.0

Il comando precedente configura l’IP 192.168.6.1/24 sull’interfaccia chiamata vlan10 (il parametro name usato in precedenza) e specifica anche l’indirizzo di rete (192.168.6.0). Così configurata, l’interfaccia fisica ether1 trasporterà i pacchetti taggati con vlan-id 10, esattamente come l’interfaccia fa0/1 dell’esempio relativo allo switch Cisco.

Ho una RouterBoard, che me ne faccio?

Alla fine dello scorso anno, come “regalo di Natale”, mi sono comprato una RouterBoard RB2011 della MikroTik, quella formato rack-mount (così a avere qualcosa con cui riempire il mio desolato armadietto rack casalingo). Dopo l’iniziale entusiasmo, ho scoperto che questo genere di “appliance” – come dicono i professionisti – è sì ricca di feature e piena di potenzialità, ma è anche particolarmente ostica da configurare se si vuole andare un po’ oltre il tipico utilizzo casalingo. Leggi tutto “Ho una RouterBoard, che me ne faccio?”

Curare il colon

Ho appena finito di leggere l’e-book “Curare il colon”, a cura dell’Istituto Riza. Ovviamente niente di nuovo sotto al sole. Oltre a dipendere dall’alimentazione, la colite, quando non dipende da vere e proprie patologie mediche, è causata dallo stress, dalle tensioni, dalla repressione delle emozioni (sia belle che brutte) e dai tanti vaffanculi e porchidii non detti. La necessità del controllo e dell’autocontrollo, sempre e comunque, fanno il resto.
Tutto sommato un libro banale, per chi questa cose le conosce già, peggiorato però dai tanti consigli sui rimedi “verdi” o naturali, come omeopatia e fiori di Bach. Vabbè che chi sta male crede un po’ a qualsiasi cosa, ma a tutto c’è un limite.
(Immagine in evidenza presa da Wikipedia)

Il futuro è elettrico

Tenta il suicidio respirando i fumi di scarico della sua Tesla. Muore di infarto dopo aver ricevuto la bolletta dell’ENEL.