Flash: pulse secure su Ubuntu 18.04

Di recente ho installato Ubuntu 18.04 e successivamente ho tentato di installare il client VPN Pulse Secure ma, a differenza di quanto avveniva con Ubuntu 16.04, in questo nuovo sistema il client non funzionava. Facendo un minimo di troubleshooting elementare, tentando di avviare il client grafico dalla command line, ho scoperto che mancavano un paio di pacchetti, vale a dire:

  • libcanberra-gtk-module
  • libwebkitgtk-1.0-0

Installando questi due pacchetti, il client ha trovato le sue librerie mancanti e ha ripreso a funzionare come atteso, sia pure con qualche warning come descritto su questa pagina. Alla data in cui scrivo questo post (13 luglio 2018) il problema è ancora irrisolto ma è stato marcato come “Solved” per errore. Tuttavia le connessioni VPN vanno a buon fine.

PS: il layout di questo articolo è abbastanza penoso… 🙁