Fregature on-line: il caso Play Sea

Occupandomi di sicurezza informatica, raccontare questo episodio non mi fa fare una gran bella figura, ma d’altra parte serve a dimostrare che nessuno è immune e che non bisogna mai abbassare la guardia.

Si stava avvicinando il compleanno di mia figlia e quindi bisognava scegliere un regalo da parte di mamma e papà, e quando si tratta cercare regali mia moglie è molto più attiva e veloce di me. Quindi solitamente succede che lei trova il giusto regalo (quasi sempre on-line), mi manda il link e io pago. Nel 90% dei casi si tratta di comprare su Amazon, altre volte su siti che accettano pagamenti via PayPal. Stranamente questa volta il link portava ad un sito che chiedeva direttamente la carta di credito, cosa un po’ rara per le mie abitudini di acquisti in rete. Tuttavia, dato che il link me lo aveva mandato una persona fidata ho dato per scontato che fosse un sito affidabile e ho proceduto alla registrazione del mio account e all’acquisto con carta di credito (in realtà una carta prepagata contenente poco più della somma che avevo preventivato di spendere). Risultato: la sessione https seguente il checkout è andata in timeout e a me non è arrivata nessuna conferma dell’acquisto. Tuttavia, riloggandomi sul sito e andando nel mio profilo, risultava che il pagamento (di  circa 146 euro) era andato a buon fine e che l’ordine era in fase “pending”. Segnalo immediatamente l’anomalia scrivendo all’indirizzo indicato per i contatti, aspettando una risposta nel giro di qualche ora. Nel frattempo continuo con i miei acquisti su altri siti (fidati). Leggi tutto “Fregature on-line: il caso Play Sea”

RouterOS – configurare le SVI

L’acronimo SVI sta per Switched Virtual Interface e, almeno nel mondo Cisco IOS, si riferisce alle interfacce layer 3 virtuali associate alle VLAN di uno switch. Configurare una SVI su uno switch Cisco è abbastanza banale, è sufficiente creare una VLAN e poi configurare la corrispondente SVI entrando nella modalità di configurazione interface vlan X (dove X è il vlan-id). Esempio:

cisco-sw# conf t
cisco-sw(config)# vlan 10
cisco-sw(config-vlan)# name server
cisco-sw(config-vlan)# exit
cisco-sw(config)# interface vlan 10
cisco-sw(config-if)# ip address 192.168.6.1 255.255.255.0
cisco-sw(config-if)# interface fa0/1
cisco-sw(config-if)# interface mode trunk
cisco-sw(config-if)# interface trunk allowed vlan 10

Nella pratica si può anche evitare la creazione esplicita della VLAN e passare direttamente alla configurazione della SVI; la vlan corrispondente sarà creata automaticamente. Le ultime righe del precedente frammento si riferiscono alla configurazione di un trunk sull’interfaccia fast ethernet 0/1 su cui transiteranno i pacchetti della vlan 10.

Veniamo ora all’argomento del post, ovvero creare una SVI su un dispositivo RouterOS. I passaggi sono un po’ meno intuitivi, soprattutto per chi non ha familiarità con la sintassi di questo sistema operativo.

Per prima cosa definiamo una nuova vlan e la colleghiamo ad una specifica interfaccia fisica:

/interface vlan
 add comment="LAN server" interface=ether1 name=vlan10 vlan-id=10

In questo modo la nostra vlan, il cui id è 10, risulta configurata sull’interfaccia ether1, che si comporterà quindi come un trunk dot1q. Il commento e il nome dell’interfaccia (parametri comment e name) sono arbitrari, ma il nome ci servirà più avanti.

Configuriamo adesso l’IP per la nostra SVI:

/ip address
 add address=192.168.6.1/24 comment="SVI vlan server" interface=vlan10 network=192.168.6.0

Il comando precedente configura l’IP 192.168.6.1/24 sull’interfaccia chiamata vlan10 (il parametro name usato in precedenza) e specifica anche l’indirizzo di rete (192.168.6.0). Così configurata, l’interfaccia fisica ether1 trasporterà i pacchetti taggati con vlan-id 10, esattamente come l’interfaccia fa0/1 dell’esempio relativo allo switch Cisco.

Ho una RouterBoard, che me ne faccio?

Alla fine dello scorso anno, come “regalo di Natale”, mi sono comprato una RouterBoard RB2011 della MikroTik, quella formato rack-mount (così a avere qualcosa con cui riempire il mio desolato armadietto rack casalingo). Dopo l’iniziale entusiasmo, ho scoperto che questo genere di “appliance” – come dicono i professionisti – è sì ricca di feature e piena di potenzialità, ma è anche particolarmente ostica da configurare se si vuole andare un po’ oltre il tipico utilizzo casalingo. Leggi tutto “Ho una RouterBoard, che me ne faccio?”

Longino, protettore dei sistemisti


Oggi, 15 marzo, si celebra San Longino, protettore dei sistemisti.
Ma perché Longino è il protettore dei sistemisti? Leggiamo insieme da Wikipedia:

Quinto Cassio Longino, in latino Longinus (Lanciano, … – Lanciano37?), è, secondo una tradizione cristiana, il nome del soldato romano che trafisse con la propria lancia il costato di Gesù crocifisso, per accertare che fosse morto, come riporta il vangelo secondo Giovanni.

Quindi, sostanzialmente, Longino fece un ping per vedere se riceveva risposta dall’host (ovvero Gesù Cristo). Come ben sappiamo noi sistemisti, in caso di mancata risposta l’host è spento o non è raggiungibile via rete, a meno che non sia configurato per non rispondere alle echo-request. Nel caso specifico di Gesù, l’host era morto.
Credits: Roberto Brigotti (NOC-PA Fastweb)
Riferimenti: https://it.m.wikipedia.org/wiki/Longino

L’Ucraina è Ucraina!

Win8.1-versione-ucraina
Qualche giorno fa una signora ucraina, amica mia e di mia moglie, mi ha chiesto di risistemarle il portatile, che da un po’ di tempo aveva iniziato a funzionare male fino a diventare totalmente inutilizzabile.
La diagnosi è stata abbastanza semplice e veloce: il disco rigido (Seagate) era gravemente danneggiato, probabilmente a causa di qualche caduta. Il rimedio è stato ovviamente quello di sostituirlo con uno di uguale capacità (500 GB), ma di una marca più affidabile* (Western Digital). Il problema è sorto al momento di ripristinare il sistema operativo. Leggi tutto “L’Ucraina è Ucraina!”